Archive for April, 2007

Apr 27 2007

Using Parallels

Published by under Mac,Windows

Well I finally started to use Windows XP in a Parallels for Mac virtual machine and Parallels is pretty slick. I’ve had a few glitches but overall it works very well. My main motivation and only use for windows is a broker supplied program that accesses and displays market data. A “Windows only” program.

The glitches:

  • After installation, which was done by my vendor, Windows XP was configured to boot directly to an “administrator” id with no need to enter a password; i.e. no security at all. Google helped to fix that when I found a Parallels forum post that said: “to use Start > Run, type “Control userpasswords2”. Then check the box that reads “Users must enter passwords…” which brings up a “User Account” tabbed control panel. That fixed it.
  • The version of parallels that I had installed, from December 2006, didn’t support USB 2.0 on a MacBook Pro. When I upgraded to a current “Beta”, Build 3188, the problem was fixed. The error message I had been getting was about something else using the USB. Not too appropriate.
  • After installing the upgrade to B3188, I started to see a message about the wrong version of Parallel Tools being in use and that I should upgrade. The message told where to find the upgrade, but I didn’t realize the virtual machine needed to be running. The upgrade is done from within windows. The warning message Referred to the “VM” menu item, but didn’t see that menu since I was running Windows in full screen mode. When I found the menus, the “Install Parallels Tools” item was in the “Actions” menu, not the VM menu. Worked fine once found.
  • There are strange and unpleasant but not disastrous interactions with “Virtue Desktop” which I use to provide multiple ‘desktops’. When in “Coherence Mode” the Windows window slide off to the side of the desktop and couldn’t be found anywhere so coherence mode doesn’t work (at the moment). Also, the interaction between Virtue and Parallels messes up the size and location of windows on other Desktop.

Postscript: Presumably due to some interaction between Virtue and Parallels, All my Virtue desktops became locked up. I couldn’t move among them and couldn’t change the windows. I logged off and then back on. When Virtue restarted a dialog said that Virtue needed to correct permissions to function properly. Worked okay after that. Virtue is no longer under development so no fix likely till 10.5 is released with its virtual desktop software.

No responses yet

Apr 15 2007

Using google video

Published by under web

Google video can be embedded in a web page by posting the video to google video and then using their docid in and object in your web page. The object is a us of a player provided by Google. Here’s an example:



That’s odd. The first parameter to an object tag seems to have to start on the same line as the object tag or else the whole page format is not rendered properly (at least in firefox). Subsequent parameter tags can be put on separate lines (as defined by a carriage return. Issue with mac vs unix carriage return?

Here’s the html that produced the above video. If cut and pasting, eliminate the return that preceeds “data=”

</p> <p><span style='text-align:center;display:block;'><br /> <object width='400' height='326' type='application/x-shockwave-flash' data='http://video.google.com/googleplayer.swf?docId=-2022406929085573519'><param name='allowScriptAccess' value='never' /><param name='movie' value='http://video.google.com/googleplayer.swf?docId=-2022406929085573519'/><param name='quality' value='best'/><param name='bgcolor' value='#440000' /><param name='scale' value='noScale' /><param name='wmode' value='window'/></object><br /> </span></p> <p>

Below is a second way to specify the video is with embed rather than object tags. As I recall use of embed is depricated and object tags encouraged. Both work about the same. Background color attributes seem to have no effect on the googleplayer application that runs the video. If cutting and pasting, you might want to merge into one line. Breaks were inserted for readability.

</p> <p><embed style="width:400px;height:326px;" type="application/x-shockwave-flash" src="http://video.google.com/googleplayer.swf?docId=-2022406929085573519&#038;hl=en" id="VideoPlayback" align="middle" quality="best" bgcolor="#ffffff" scale="noScale" salign="TL" FlashVars="playerMode=embedded"></embed></p> <p>

No responses yet