Nov 18 2007

2nd Round – Upgrade to 10.5 (Leopard)

Published by at 9:20 pm under General

Items not handled by the install process:

  • Developer’s tools are not migrated. Tried copying to / from /Previous System. Some apps work and some don’t xCode doesn’t! Have to reinstall from a 1.1GB download (or off the install DVD)! Works fine after a re-install.
  • gimp.app an OS X version of the gimp graphics manipulation program compiled to use X11 cratered on launch. Off to find a more current version? The one that cratered was over a year old (gimp-2.2 [940]). It says it is caching fonts and then dies.
    Downloaded another binary version (gimp-2.2 [1172]) that is supposed to work with Leopard and it cratered while loading fonts. The download was from sourceforge via a link from Apple’s download page. Time to read the log which says:

    11/18/07 3:48:22 PM [0x0-0x9e09e].org.gimp.Gimp[1158]
    Reason: Incompatible library version: libXft.2.dylib requires version 3.0.0 or later,
    but libfontconfig.1.dylib provides version 2.0.0

    hmmm. I hate this sort of chase the module problem. A waste of time. Macports has a version of gimp. Maybe I’ll try that instead.

  • And then there are the other Unix style applications that are left on “Previous System” and have to be copied over or re-installed. In addition to gimp, I need the Haskell compiler (GHC), and the GPG suite of tools.

On the other hand, Windows XP under VMWare runs fine though I did have to upgrade to VMWare Fusion V1.1.

No responses yet

Trackback URI | Comments RSS

Leave a Reply